Jump to content

Welcome to Autoworld Forum !

Sign In or Register to gain full access to our forums. By registering with us, you'll be able to discuss, share and private message with other members of our community.

Close
Photo

Engine Mounting For Saga Lmst


  • Please log in to reply

#1
chris7027

Posted 10 May 2009 - 06:44 PM

chris7027

    Veteran

  • Members
  • PipPip
  • 238 posts
Hi.....

My 5 years old saga lmst dashboard vibrate too much due to worn engine mounting.....
I was thinnking of replacing de mounting but anyone knows how much it cost ?
Should i change at PESC or get from outside shop ?
Any brand (if any) to recomend me, as my budget is only RM350...

Anyone knows how they change de mounting..?
Someone said they have to bring down de engine from de engine bay 1st..is it true..?
If its true that mean its a very difficult task & might take whole day to repalce de mounting..... sad.gif

Thanks... ;-)

#2
drexchan

Posted 10 May 2009 - 07:10 PM

drexchan

    Hot Rod

  • Members
  • PipPipPipPip
  • 14,758 posts
It's not a dificult job but the price is within the range of market price, for original parts.

#3
YSW

Posted 10 May 2009 - 07:53 PM

YSW

    Road Warrior

  • Members
  • PipPip
  • 864 posts
QUOTE (drexchan @ May 10 2009, 07:10 PM) <{POST_SNAPBACK}>
It's not a dificult job but the price is within the range of market price, for original parts.



Yup, with such budget, you should be able to get good parts and good workmanship.

#4
chris7027

Posted 10 May 2009 - 08:44 PM

chris7027

    Veteran

  • Members
  • PipPip
  • 238 posts
Is it.....?

I was quoted today for full sets mounting is RM300-RM400 for cap ayam brand & RM500-RM700 for branded ones. . .Both include labour charges..... Is de labour charges so high...? There is also no warranty for cap ayam & branded one...

I called de PESC & they quote me full sets original proton mounting with labour charges is RM1,000 ++....warranty is 1 year...

Will engine mounting have warranty to install....?

Any comments.... :-)

#5
drexchan

Posted 10 May 2009 - 09:35 PM

drexchan

    Hot Rod

  • Members
  • PipPipPipPip
  • 14,758 posts
You should visit another dealer/service center/workshop.

#6
limking

Posted 10 May 2009 - 09:40 PM

limking

    Tokyo Drifter

  • Members
  • PipPipPip
  • 2,881 posts
QUOTE (chris7027 @ May 10 2009, 08:44 PM) <{POST_SNAPBACK}>
Is it.....?

I was quoted today for full sets mounting is RM300-RM400 for cap ayam brand & RM500-RM700 for branded ones. . .Both include labour charges..... Is de labour charges so high...? There is also no warranty for cap ayam & branded one...

I called de PESC & they quote me full sets original proton mounting with labour charges is RM1,000 ++....warranty is 1 year...

Will engine mounting have warranty to install....?

Any comments.... :-)

Wow ! so much , ah . suggested you buy your own mounting parts from autoparts shop and later have a mechanic to fix it up for you. Labour charges should be around RM80 - RM100 max. Did my Wira's engine mountings recently about 2 months ago : RM400 inclusive of 100% genuine proton engine mounting parts and labour . smile_thumbup.gif





PATIENCE !!! PATIENCE !!! PATIENCE !!! IT'LL GET YOU THE BEST WHEN TIME IS RIGHT AND SO WILL BE THE PRICE

#7
cfa

Posted 15 May 2009 - 01:03 PM

cfa

    Road Warrior

  • Members
  • PipPip
  • 833 posts
EON seems to have promotion for engine mounting

http://www.eon.com.m...tion.cfm?id=167



#8
chris7027

Posted 15 May 2009 - 07:47 PM

chris7027

    Veteran

  • Members
  • PipPip
  • 238 posts
Few months ago...I had change my right & left drive shaft when my saga lmst got de "tak tak tak" sound when turning & moving slowly..... After change...de sound is gone...

Now...de sound "tak tak tak" come back again.....But de sound only appear in de morning when i want to drive my car out slowly from de car porch to turn left or right... After driving straight & warm up..no more sound liao...

But de sound also appear when i want to turn de car slowly to park at parking lots.... Any other time got no sound de...?

Wats seems to be de peroblem? Where de sound coming from?
Is it de lower arm or its bushing or its joints...?
Any commnents...?

Thansks...