Jump to content

Welcome to Autoworld Forum !

Sign In or Register to gain full access to our forums. By registering with us, you'll be able to discuss, share and private message with other members of our community.

Close
Photo

Vios Engine Light "ON"!


  • Please log in to reply

#1
kjhgsl

Posted 18 April 2006 - 08:37 AM

kjhgsl

    Probation

  • Members
  • Pip
  • 22 posts
Last week, I have problem with my vios, the engine light in the meter
panel turn "ON" during the bad traffic jam. According to the operation
manual there are something wrong in the fuel tank indicator and other's
part of engine. Send to SC for further detail checking and found that the
connector was loose from the engine part. My colleague Vios also facing
this problem and found that the sensor is not working. Did any body
facing this problem on your Vios.

#2
Stephenr

Posted 18 April 2006 - 04:09 PM

Stephenr

    Road Warrior

  • Members
  • PipPip
  • 600 posts
hi kjhgsl , what year is your vios? did the SC manage to resolve the
problem after fix back the loose part. pls share more.


#3
azbro

Posted 19 April 2006 - 10:03 AM

azbro

    Tokyo Drifter

  • Members
  • PipPipPip
  • 4,856 posts
Yup... me also kena...my mechanic did some 'rewiring' to attach a hidden
switch....a week later the engine light 'on'.

Went to the service center...toke me 10 mins to get the car back. They
also said some connection loose. Seems like this is a know problem for the
Vios.

#4
john

Posted 19 April 2006 - 11:26 AM

john

    Fast & Furious

  • Members
  • PipPipPip
  • 1,012 posts
If you have been using K&N filter or those open pods type, chances are that the EGR sensor is dirty.
The trottle body and sensor I think needs to be cleaned and the system reset. Mine was done by
UMW Toyota and using back the original filter now. ( Error code - insufficient air received i.e. sensor
not detecting the volume of air as it should)

BTW who wants to buy my less than 1 year old K&N filter?

Hope this helps




#5
kjhgsl

Posted 19 April 2006 - 11:31 AM

kjhgsl

    Probation

  • Members
  • Pip
  • 22 posts
My car only 18 months old and my colleague also same with me. My car was
sent to Balakong SC on last Saturday and until today still in normal
condition.The manager (after sales) in Balakong SC was very helpful and
solve my problem. My colleague send to Segambut SC for trouble shooting
but unfortunately the light turn "ON" again after one week and send to
Segambut SC again for checking and was told that the wiring loose at the
connector. Until now in normal condition. This would be common technical
problem on the vios.