Jump to content

Welcome to Autoworld Forum !

Sign In or Register to gain full access to our forums. By registering with us, you'll be able to discuss, share and private message with other members of our community.

Close
Photo

Waja Cannot Start


  • Please log in to reply

#1
wang26

Posted 11 February 2015 - 02:49 PM

wang26

    1st Gear

  • Members
  • 1 posts
Hi to all Wajarians,
Im newbie here
Im driving 2003 Waja (A) - Mitsu Eng.
Im quite satisfied with the performance until today smile_thumbup.gif
(bought it sec. hand)


This morning I cannot start my car,
Radio can ON, Light can ON, AC also can
But not to start the engine... (Choaking only... Chehehehek.... chehehehek...)
Weird thing is ... In the indicator panel I see the battery light and engine oil is ON
FYI, I just change the engine oil few weeks ago.
The previous day I just pump fuel to nearly full tank.

I haven't try JUMP start.
But What is the possible problem that happened with my car??
It shouldn't be ECU, Fuel Pump Failure or the Wiring rte?
Anyone had experience this matter before?

Thank you!

#2
vr2turbo

Posted 12 February 2015 - 08:44 AM

vr2turbo

    Forum Ninja

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 70,307 posts
  • Gender:Male
QUOTE (wang26 @ Feb 11 2015, 02:49 PM) <{POST_SNAPBACK}>
Hi to all Wajarians,
Im newbie here
Im driving 2003 Waja (A) - Mitsu Eng.
Im quite satisfied with the performance until today smile_thumbup.gif
(bought it sec. hand)


This morning I cannot start my car,
Radio can ON, Light can ON, AC also can
But not to start the engine... (Choaking only... Chehehehek.... chehehehek...)
Weird thing is ... In the indicator panel I see the battery light and engine oil is ON
FYI, I just change the engine oil few weeks ago.
The previous day I just pump fuel to nearly full tank.

I haven't try JUMP start.
But What is the possible problem that happened with my car??
It shouldn't be ECU, Fuel Pump Failure or the Wiring rte?
Anyone had experience this matter before?

Thank you!

Is the crank strong? If weak, then is battery problem....try jump start....

#3
Gunnerzz

Posted 12 February 2015 - 02:11 PM

Gunnerzz

    Tokyo Drifter

  • Members
  • PipPipPip
  • 3,102 posts
QUOTE (vr2turbo @ Feb 12 2015, 08:44 AM) <{POST_SNAPBACK}>
Is the crank strong? If weak, then is battery problem....try jump start....

If it still wont start then it could be the fuel pump.
Common among waja as its very old already.

not sure if the waja already using the small chip immoboliser in the key like alltheir newer car.
if yes then try using the spare key.

#4
kohf1drive

Posted 16 May 2015 - 02:42 PM

kohf1drive

    Tokyo Drifter

  • Members
  • PipPipPip
  • 3,067 posts
Check your fuel pump
Your starter is turning but no fuel delivered to engine