Jump to content

Welcome to Autoworld Forum !

Sign In or Register to gain full access to our forums. By registering with us, you'll be able to discuss, share and private message with other members of our community.

Close
Photo

Infinitum Battery Desulfator Review


  • Please log in to reply

#31
cute_boboi

Posted 19 June 2014 - 10:14 AM

cute_boboi

    Heart Like a Wheel

  • Members
  • PipPipPipPipPipPip
  • 23,882 posts
QUOTE (justdoit @ Jun 9 2014, 08:13 AM) <{POST_SNAPBACK}>
My Century Marathon lasted 28 months that came with 18 months warranty. The battery died while stucked in traffic jam. The towing truck guy jump started the battery and next day the car could be started easily. So I went to the shop and checked the charge and the reading was still ok, puzzling with the reading, the shop worker asked his boss to check further. The boss way of checking was to hold on the check button for 5-10 seconds before releasing it. And the reading did slowly decreased showing the condition of the battery was deteriorating and immediately i changed a new one.


If car is running, and alternator is working, even if take out battery, the engine probably won't die ?


On another note, last Fri the crank took 1 second longer and immediate I feel the car battery going to die.
Weekend car cannot start. Checked and replaced.
Old battery taken out = 11.8V can't crank anymore.
New battery with engine running = 14.2V (60Ah, 680A cold cranking amps)

"When Columbus started out he didn`t know where he was going. When he got there he didn`t know where he was and when he got back he didn`t know where he had been." - Anonymous

#32
vr2turbo

Posted 20 June 2014 - 10:39 AM

vr2turbo

    Forum Ninja

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 69,742 posts
  • Gender:Male
QUOTE (cute_boboi @ Jun 19 2014, 10:14 AM) <{POST_SNAPBACK}>
If car is running, and alternator is working, even if take out battery, the engine probably won't die ?


On another note, last Fri the crank took 1 second longer and immediate I feel the car battery going to die.
Weekend car cannot start. Checked and replaced.
Old battery taken out = 11.8V can't crank anymore.
New battery with engine running = 14.2V (60Ah, 680A cold cranking amps)

My dead battery still show 12.6v but no juice to crank, so change battery and problem solved... smile_tongue.gif

#33
justdoit

Posted 24 June 2014 - 04:13 PM

justdoit

    Veteran

  • Members
  • PipPip
  • 227 posts
QUOTE (vr2turbo @ Jun 20 2014, 10:39 AM) <{POST_SNAPBACK}>
My dead battery still show 12.6v but no juice to crank, so change battery and problem solved... smile_tongue.gif

After two weeks, the battery showed wekness again. Went to the shop next day and changed the alternator because there was no movement of the reading. I suspect the tow truck guy jump started the battery and damaged the alternator. He connected the earth cable straight to the battery instead of the car body because my alternator only one and a half year old but its a recond one.
moon

#34
vr2turbo

Posted 25 June 2014 - 08:12 AM

vr2turbo

    Forum Ninja

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 69,742 posts
  • Gender:Male
QUOTE (justdoit @ Jun 24 2014, 04:13 PM) <{POST_SNAPBACK}>
After two weeks, the battery showed wekness again. Went to the shop next day and changed the alternator because there was no movement of the reading. I suspect the tow truck guy jump started the battery and damaged the alternator. He connected the earth cable straight to the battery instead of the car body because my alternator only one and a half year old but its a recond one.

My recon alternator also lasted about that period only. Nowadays even brand new alternator have no warranty..... smile_blackeye.gif

#35
justdoit

Posted 25 June 2014 - 02:11 PM

justdoit

    Veteran

  • Members
  • PipPip
  • 227 posts
QUOTE (vr2turbo @ Jun 25 2014, 08:12 AM) <{POST_SNAPBACK}>
My recon alternator also lasted about that period only. Nowadays even brand new alternator have no warranty..... smile_blackeye.gif

Wah, are we going to buy alternator like buying battery?
Another one bites the dust.
moon

#36
vr2turbo

Posted 26 June 2014 - 08:23 AM

vr2turbo

    Forum Ninja

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 69,742 posts
  • Gender:Male
QUOTE (justdoit @ Jun 25 2014, 02:11 PM) <{POST_SNAPBACK}>
Wah, are we going to buy alternator like buying battery?
Another one bites the dust.

My friend's recon unit also lasted 2 years only. Since the car driven by his wife, he opt for original this time around, but the price is RM700 compared to RM200, so see how it goes. The original RM700 one also no warranty.... smile_blackeye.gif

#37
justdoit

Posted 26 June 2014 - 12:31 PM

justdoit

    Veteran

  • Members
  • PipPip
  • 227 posts
QUOTE (vr2turbo @ Jun 26 2014, 08:23 AM) <{POST_SNAPBACK}>
My friend's recon unit also lasted 2 years only. Since the car driven by his wife, he opt for original this time around, but the price is RM700 compared to RM200, so see how it goes. The original RM700 one also no warranty.... smile_blackeye.gif


My ori that came with the new car lasted 6 years 2 months.
moon

#38
vr2turbo

Posted 27 June 2014 - 08:37 AM

vr2turbo

    Forum Ninja

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 69,742 posts
  • Gender:Male
QUOTE (justdoit @ Jun 26 2014, 12:31 PM) <{POST_SNAPBACK}>
My ori that came with the new car lasted 6 years 2 months.

Most original that comes with the car last much longer. It is those that are changed that don't last..... smile_blackeye.gif

#39
abz2000

Posted 04 January 2016 - 11:15 PM

abz2000

    2nd Gear

  • Members
  • 2 posts
I posted this yesterday but it doesn't appear to show so i'll re-post it:
....


Guys, i received a 12v green lettering infinifum which i purchased on ebay, i put the batteries on charge and attached the desulfator to one of the batteries and it wasn't apparent that anything was happening other than the green indicator led showing that the voltage on one of the battery was above 12v or whatever threshold is set, later in the evening i put a multimeter on the end of the joints and for around 10-20 minutes watched the voltage continue to slowly rise on all the batteries as normal when charging but saw no voltage spikes whatsoever on the one with the desufator attached.

How is it possible that anything is happening with this desufator when there are no voltage spikes over the course of at least ten minutes?
has anyone else tried to test for voltage patterns?
Please review and advise,

Abz Computers