Jump to content

Welcome to Autoworld Forum !

Sign In or Register to gain full access to our forums. By registering with us, you'll be able to discuss, share and private message with other members of our community.

Close
Photo

Check Engine Light On And Off During Driving


  • Please log in to reply

#1
bktang

Posted 21 January 2009 - 10:57 AM

bktang

    Advanced

  • Members
  • Pip
  • 85 posts
Hi Sifu sekalian,

My wira 1.6xli check engine light is on and off during driving. The check engine light will on for few seconds during driving and off later. Any idea what wrong it that? By the way, my car does look fine as no jerking and etc. I'm wondering whether need to send it to service center to check the engine tuning.

Thanks. rolleyes.gif

#2
baldwin

Posted 21 January 2009 - 11:28 AM

baldwin

    Fast & Furious

  • Members
  • PipPipPip
  • 2,093 posts
do send it in as it could probably be one of the sensors giving way already..

#3
bktang

Posted 21 January 2009 - 01:30 PM

bktang

    Advanced

  • Members
  • Pip
  • 85 posts
QUOTE (baldwin @ Jan 21 2009, 12:28 PM) <{POST_SNAPBACK}>
do send it in as it could probably be one of the sensors giving way already..


thx for the replied. normally how much do I need to spend if the sensor faulty? does it relate to the Throttle body?

#4
mych

Posted 22 January 2009 - 01:05 AM

mych

    White Lightning

  • Members
  • PipPipPip
  • 7,780 posts
QUOTE (bktang @ Jan 21 2009, 01:30 PM) <{POST_SNAPBACK}>
thx for the replied. normally how much do I need to spend if the sensor faulty? does it relate to the Throttle body?


you know how to read the code?

http://www.idmoc.com...0DIAGNOSTIC.pdf

Mych

#5
kohf1drive

Posted 22 January 2009 - 07:16 AM

kohf1drive

    Tokyo Drifter

  • Members
  • PipPipPip
  • 3,052 posts
Last time, my car jerk (+engine light on) with engine going to shut of during cruising
Then went to workshop check found the positive terminal loose, tighten it. Now so far no problem

#6
beemc

Posted 22 January 2009 - 06:10 PM

beemc

    Veteran

  • Members
  • PipPip
  • 173 posts
hey guy...i'm having da same problem in my 1996 wira 1.6XLi... da check engine light is on and off after few minutes... went to proton servis center for scanning...and da error codes are 'ignition coil open' and 'knock sensor'...replaced with second hand knock sensor but it still come out... and my car hav serious jerking prob... it will then suddenly die off and very diff to start da engine again....can u guys help me with it? sad.gif sad.gif

#7
bktang

Posted 22 January 2009 - 07:00 PM

bktang

    Advanced

  • Members
  • Pip
  • 85 posts
QUOTE (beemc @ Jan 22 2009, 07:10 PM) <{POST_SNAPBACK}>
hey guy...i'm having da same problem in my 1996 wira 1.6XLi... da check engine light is on and off after few minutes... went to proton servis center for scanning...and da error codes are 'ignition coil open' and 'knock sensor'...replaced with second hand knock sensor but it still come out... and my car hav serious jerking prob... it will then suddenly die off and very diff to start da engine again....can u guys help me with it? sad.gif sad.gif


I just send my car to service center today and they've check the tuning with MUT-II. They claim got error code saying the air flow to ekzoz got problem and have reset the code and spray some cleaner to clean the TB. Total spend is RM70. I'm monitoring it now whether the problem resolve or not else have to send back for them to check.

beemc,
i'm not sure what ur problem is. It may relate to your TB because I've my car jerking during driving and die off when waiting for traffic light few years back. I've send my car to check then they've changed the ISC gear in the TB but it won't last long. After 3rd set of ISC gear been changed but it happen again, so I decide to change a new TB and it last me for few year till now before i got this check engine light on and off intermittent during driving.(Touch wood)

#8
beemc

Posted 23 January 2009 - 04:37 PM

beemc

    Veteran

  • Members
  • PipPip
  • 173 posts
QUOTE (bktang @ Jan 22 2009, 07:00 PM) <{POST_SNAPBACK}>
I just send my car to service center today and they've check the tuning with MUT-II. They claim got error code saying the air flow to ekzoz got problem and have reset the code and spray some cleaner to clean the TB. Total spend is RM70. I'm monitoring it now whether the problem resolve or not else have to send back for them to check.

beemc,
i'm not sure what ur problem is. It may relate to your TB because I've my car jerking during driving and die off when waiting for traffic light few years back. I've send my car to check then they've changed the ISC gear in the TB but it won't last long. After 3rd set of ISC gear been changed but it happen again, so I decide to change a new TB and it last me for few year till now before i got this check engine light on and off intermittent during driving.(Touch wood)


thx bktang...i'll consider bout da TB... but da mechanic said most probally is the distributor... i hav changed a re-cond distributor few yrs ago due to da same jerking prob... after changing it... da prob solved... but now... da mechanic not sure izzzit bcoz of da distributor again... sad.gif ...even da mechanic from proton cant comfirm da main prob...